Monday, April 23, 2007

acroread expr syntax error (Adobe Reader for Linux)

Solution is here.
http://linuxon-vgn-a497xp.blogspot.com/2006/11/acroread-expr-syntax-error.html

But basically, you comment out the appropriate lines using the # operator in the acroread startup script (usually located in /usr/bin/). Here are the modifications.

418# echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
419 echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

644# MIN_GTK_VERSION="240"
645 MIN_GTK_VERSION="2040"

3 comments:

Zinnia said...

Well said.

Kavan said...

Thanks a lot!!!!!!!!!

buy generic cialis online said...

Well worth to read this article, thanks for sharing this information. With this article you offered me got a chance to know about this, anyway i say Great Article! and waiting for you next article about this interesting subject.